<!DOCTYPE html>
<html lang="en-US" id="arve">
<head >
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.4.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Jerone Davison Campaign Ad: Make Rifles Great Again | MissLiberty.com</title>
	<meta name="description" content="AZ Republican Congressional candidate Jerone Davison has produced one of the greatest pro-Second Amendment campaign commercials ever made." />
	<link rel="canonical" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Jerone Davison Campaign Ad: Make Rifles Great Again | MissLiberty.com" />
	<meta property="og:description" content="AZ Republican Congressional candidate Jerone Davison has produced one of the greatest pro-Second Amendment campaign commercials ever made." />
	<meta property="og:url" content="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" />
	<meta property="og:site_name" content="Miss Liberty&#039;s Film &amp; Documentary World" />
	<meta property="article:publisher" content="https://www.facebook.com/libertarianfilm" />
	<meta property="article:published_time" content="2022-07-08T14:01:49+00:00" />
	<meta property="article:modified_time" content="2022-07-08T14:02:46+00:00" />
	<meta property="og:image" content="https://missliberty.com/wp-content/uploads/2022/07/jerone-davison-campaign-ad-make.jpg" />
	<meta property="og:image:width" content="1280" />
	<meta property="og:image:height" content="720" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="AdminML" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="1 minute" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://missliberty.com/#website","url":"https://missliberty.com/","name":"Miss Liberty&#039;s Film &amp; Documentary World","description":"Libertarian Movies, Films &amp; Documentaries","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://missliberty.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/#primaryimage","inLanguage":"en-US","url":"https://i0.wp.com/missliberty.com/wp-content/uploads/2022/07/jerone-davison-campaign-ad-make.jpg?fit=1280%2C720&ssl=1","contentUrl":"https://i0.wp.com/missliberty.com/wp-content/uploads/2022/07/jerone-davison-campaign-ad-make.jpg?fit=1280%2C720&ssl=1","width":1280,"height":720,"caption":"jerone davison"},{"@type":"WebPage","@id":"https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/#webpage","url":"https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/","name":"Jerone Davison Campaign Ad: Make Rifles Great Again | MissLiberty.com","isPartOf":{"@id":"https://missliberty.com/#website"},"primaryImageOfPage":{"@id":"https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/#primaryimage"},"datePublished":"2022-07-08T14:01:49+00:00","dateModified":"2022-07-08T14:02:46+00:00","author":{"@id":"https://missliberty.com/#/schema/person/f50b8df5fb48c702caab51b48a392639"},"description":"AZ Republican Congressional candidate Jerone Davison has produced one of the greatest pro-Second Amendment campaign commercials ever made.","breadcrumb":{"@id":"https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/"]}]},{"@type":"BreadcrumbList","@id":"https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://missliberty.com/"},{"@type":"ListItem","position":2,"name":"Jerone Davison Campaign Ad: Make Rifles Great Again"}]},{"@type":"Person","@id":"https://missliberty.com/#/schema/person/f50b8df5fb48c702caab51b48a392639","name":"AdminML","url":"https://missliberty.com/author/adminml/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Miss Liberty&#039;s Film &amp; Documentary World &raquo; Feed" href="https://missliberty.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Miss Liberty&#039;s Film &amp; Documentary World &raquo; Comments Feed" href="https://missliberty.com/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.3.2 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-51541631-1"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/missliberty.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='genesis-simple-share-plugin-css-css'  href='https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/css/share.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-genericons-css-css'  href='https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/css/genericons.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='miss-liberty-css'  href='https://missliberty.com/wp-content/themes/missliberty/style.min.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://missliberty.com/wp-includes/css/dist/block-library/style.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://missliberty.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://missliberty.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.9.3' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='social-icons-general-css'  href='//missliberty.com/wp-content/plugins/social-icons/assets/css/social-icons.css?ver=1.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://missliberty.com/wp-includes/css/dashicons.min.css?ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='missliberty-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto:300,400|Raleway:400,500,900' type='text/css' media='all' />
<link rel='stylesheet' id='simple-social-icons-font-css'  href='https://missliberty.com/wp-content/plugins/simple-social-icons/css/style.css?ver=3.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://missliberty.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://missliberty.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.5.1' type='text/css' media='all' />
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/jetpack/_inc/build/related-posts/related-posts.min.js?ver=20211209' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0' id='genesis-simple-share-plugin-js-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/waypoints.min.js?ver=0.1.0' id='genesis-simple-share-waypoint-js-js'></script>
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/missliberty.com","hash_tracking":"false","ua":"UA-51541631-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.3.2' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/simple-social-icons/svgxuse.js?ver=1.1.21' id='svg-x-use-js'></script>
<link rel="https://api.w.org/" href="https://missliberty.com/wp-json/" /><link rel="alternate" type="application/json" href="https://missliberty.com/wp-json/wp/v2/posts/21438" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://missliberty.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://missliberty.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://wp.me/p8oZdY-5zM' />
<link rel="alternate" type="application/json+oembed" href="https://missliberty.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmissliberty.com%2Fjerone-davison-campaign-ad-make-rifles-great-again%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://missliberty.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmissliberty.com%2Fjerone-davison-campaign-ad-make-rifles-great-again%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
	<link rel="icon" href="https://i0.wp.com/missliberty.com/wp-content/uploads/2016/09/cropped-favicon.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/missliberty.com/wp-content/uploads/2016/09/cropped-favicon.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/missliberty.com/wp-content/uploads/2016/09/cropped-favicon.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/missliberty.com/wp-content/uploads/2016/09/cropped-favicon.png?fit=270%2C270&#038;ssl=1" />
</head>
<body class="post-template-default single single-post postid-21438 single-format-standard header-full-width content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-visible primary-nav"><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-dark-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0.49803921568627" /><feFuncG type="table" tableValues="0 0.49803921568627" /><feFuncB type="table" tableValues="0 0.49803921568627" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-grayscale"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.54901960784314 0.98823529411765" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.71764705882353 0.25490196078431" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-red"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 1" /><feFuncG type="table" tableValues="0 0.27843137254902" /><feFuncB type="table" tableValues="0.5921568627451 0.27843137254902" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-midnight"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0 0" /><feFuncG type="table" tableValues="0 0.64705882352941" /><feFuncB type="table" tableValues="0 1" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-magenta-yellow"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.78039215686275 1" /><feFuncG type="table" tableValues="0 0.94901960784314" /><feFuncB type="table" tableValues="0.35294117647059 0.47058823529412" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-purple-green"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.65098039215686 0.40392156862745" /><feFuncG type="table" tableValues="0 1" /><feFuncB type="table" tableValues="0.44705882352941 0.4" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><svg xmlns="http://www.w3.org/2000/svg" viewBox="0 0 0 0" width="0" height="0" focusable="false" role="none" style="visibility: hidden; position: absolute; left: -9999px; overflow: hidden;" ><defs><filter id="wp-duotone-blue-orange"><feColorMatrix color-interpolation-filters="sRGB" type="matrix" values=" .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 .299 .587 .114 0 0 " /><feComponentTransfer color-interpolation-filters="sRGB" ><feFuncR type="table" tableValues="0.098039215686275 1" /><feFuncG type="table" tableValues="0 0.66274509803922" /><feFuncB type="table" tableValues="0.84705882352941 0.41960784313725" /><feFuncA type="table" tableValues="1 1" /></feComponentTransfer><feComposite in2="SourceGraphic" operator="in" /></filter></defs></svg><div class="site-container"><nav class="nav-primary" aria-label="Main"><div class="wrap"><ul id="menu-top-menu" class="menu genesis-nav-menu menu-primary"><li id="menu-item-9273" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-9273"><a href="https://missliberty.com/"><span >Home</span></a></li>
<li id="menu-item-19882" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-19882"><a href="https://missliberty.com/category/news/"><span >News</span></a></li>
<li id="menu-item-19876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19876"><a><span >Top Picks</span></a>
<ul class="sub-menu">
	<li id="menu-item-19879" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19879"><a href="https://missliberty.com/libertarian-movies-films-top-25/"><span >Movies &#038; Films: Top 25</span></a></li>
	<li id="menu-item-19880" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19880"><a href="https://missliberty.com/libertarian-documentaries-the-top-25/"><span >Documentaries: Top 25</span></a></li>
	<li id="menu-item-19877" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19877"><a href="https://missliberty.com/libertarian-movies-for-students-top-ten/"><span >Films For Students: Top 10</span></a></li>
	<li id="menu-item-19878" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-19878"><a href="https://missliberty.com/libertarian-music-videos-the-top-10/"><span >Music Videos: Top 10</span></a></li>
</ul>
</li>
<li id="menu-item-19883" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-19883"><a><span >Categories</span></a>
<ul class="sub-menu">
	<li id="menu-item-19884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19884"><a href="https://missliberty.com/category/film/"><span >Film</span></a></li>
	<li id="menu-item-19885" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19885"><a href="https://missliberty.com/category/doc/"><span >Documentary</span></a></li>
	<li id="menu-item-19886" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-19886"><a href="https://missliberty.com/category/shorts/"><span >Shorts</span></a></li>
	<li id="menu-item-19887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19887"><a href="https://missliberty.com/category/blog/"><span >Blog</span></a></li>
	<li id="menu-item-9276" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9276"><a href="https://missliberty.com/libertarian-calendar-films-movies-documentaries/"><span >Calendar</span></a></li>
	<li id="menu-item-9275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9275"><a href="https://missliberty.com/libertarian-film-links-resources/"><span >Links</span></a></li>
	<li id="menu-item-9274" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9274"><a href="https://missliberty.com/aboutlibertarianism/"><span >About</span></a></li>
</ul>
</li>
</ul></div></nav><header class="site-header"><div class="wrap"><div class="title-area"><p class="site-title"><a href="https://missliberty.com/">Miss Liberty&#039;s Film &amp; Documentary World</a></p><p class="site-description">Libertarian Movies, Films &amp; Documentaries</p></div></div></header><div class="site-inner"><div class="content-sidebar-wrap"><main class="content"><article class="post-21438 post type-post status-publish format-standard has-post-thumbnail category-news category-shorts entry" aria-label="Jerone Davison Campaign Ad: Make Rifles Great Again"><header class="entry-header"><h1 class="entry-title">Jerone Davison Campaign Ad: Make Rifles Great Again</h1>
</header><div class="entry-content"><div class="share-before share-filled share-small" id="share-before-21438"><div class="googlePlus" id="googleplus-before-21438" data-url="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" data-urlalt="https://wp.me/p8oZdY-5zM" data-text="Jerone Davison Campaign Ad: Make Rifles Great Again" data-title="Share" data-reader="Share on Google Plus" data-count="%s shares on Google Plus"></div><div class="facebook" id="facebook-before-21438" data-url="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" data-urlalt="https://wp.me/p8oZdY-5zM" data-text="Jerone Davison Campaign Ad: Make Rifles Great Again" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-21438" data-url="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" data-urlalt="https://wp.me/p8oZdY-5zM" data-text="Jerone Davison Campaign Ad: Make Rifles Great Again" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="pinterest" id="pinterest-before-21438" data-url="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" data-urlalt="https://wp.me/p8oZdY-5zM" data-text="Jerone Davison Campaign Ad: Make Rifles Great Again" data-title="Pin" data-reader="Pin this" data-count="%s Pins"></div><div class="linkedin" id="linkedin-before-21438" data-url="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" data-urlalt="https://wp.me/p8oZdY-5zM" data-text="Jerone Davison Campaign Ad: Make Rifles Great Again" data-title="Share" data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div><div class="stumbleupon" id="stumbleupon-before-21438" data-url="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/" data-urlalt="https://wp.me/p8oZdY-5zM" data-text="Jerone Davison Campaign Ad: Make Rifles Great Again" data-title="Share" data-reader="Share on StumbleUpon" data-count="%s shares on StumbleUpon"></div></div>
			<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#googleplus-before-21438').sharrre({
										  share: {
										    googlePlus: true
										  },
										  urlCurl: 'https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('googlePlus');
										  }
										});
$('#facebook-before-21438').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-21438').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#pinterest-before-21438').sharrre({
										  share: {
										    pinterest: true
										  },
										  urlCurl: 'https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  pinterest: { media: 'https://i0.wp.com/missliberty.com/wp-content/uploads/2022/07/jerone-davison-campaign-ad-make.jpg?fit=1280%2C720&ssl=1', description: 'Jerone Davison Campaign Ad: Make Rifles Great Again' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('pinterest');
										  }
										});
$('#linkedin-before-21438').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});
$('#stumbleupon-before-21438').sharrre({
										  share: {
										    stumbleupon: true
										  },
										  urlCurl: 'https://missliberty.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('stumbleupon');
										  }
										});

				});
		</script><p>Per <a href="https://pjmedia.com/news-and-politics/chris-queen/2022/07/06/black-gop-congressional-candidate-runs-the-boldest-gun-rights-ad-ever-n1610860">PJMedia</a>, Arizona Republican Congressional candidate Jerone Davison has produced one of the greatest pro-Second Amendment campaign commercials ever made: <em>Make Rifles Great Again</em>. It pounds Democrats for their anti-gun policies by reminding them just who was behind the KKK: Democrats just like <em>them</em>. Lest anyone think that is ancient history, Democrat Senator Robert Byrd, who was in office until 2010, was not only a <a href="https://en.wikipedia.org/wiki/Robert_Byrd">former member of the KKK</a> but an organizer and recruiter. He also opposed the Civil Rights Act of 1964. And yet, Democrats were fine not just reelecting him for decades but making him Senate Majority Leader until 1989. Jerone Davison hasn&#8217;t forgotten.</p>
<p>“Democrats like to say that no one needs an AR-15 for self-defense. That no one could possibly need all 30 rounds,” Davison says in the ad. “But when this rifle is the only thing standing between your family and a dozen angry Democrats in Klan hoods, you just might need that semi-automatic and all 30 rounds.”</p>
<p>Davison is a solid Constitutionalist. Per PJ Media, “Freedom is not given to us by the government,” his site states. “We have natural, or God-given, rights that should be protected by the government. Our Constitution keeps us free. We must work to keep these freedoms and have executive, legislative, and judicial leaders that will adhere to the Constitution. I stand with Constitutionalists.”</p>
<p>Reason had a <a href="https://reason.com/2005/02/15/the-klans-favorite-law/">good article</a> on how gun control was the Klan&#8217;s favorite law.</p>
<div class="arve-wrapper" data-mode="normal" data-provider="youtube" id="arve-BVRxzoKQ8Zk" style="max-width:1140px;" itemscope itemtype="http://schema.org/VideoObject"><div class="arve-embed-container" style="padding-bottom:56.250000%"><iframe allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen class="arve-iframe fitvidsignore" frameborder="0" name sandbox="allow-scripts allow-same-origin allow-presentation allow-popups allow-popups-to-escape-sandbox" scrolling="no" src="https://www.youtube-nocookie.com/embed/BVRxzoKQ8Zk?iv_load_policy=3&#038;modestbranding=1&#038;rel=0&#038;autohide=1&#038;playsinline=1&#038;autoplay=0" width="480" height="270"></iframe></div></div>
<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-21438" class="share-twitter sd-button share-icon no-text" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-21438" class="share-facebook sd-button share-icon no-text" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-21438" class="share-linkedin sd-button share-icon no-text" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-21438" class="share-pinterest sd-button share-icon no-text" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://missliberty.com/jerone-davison-campaign-ad-make-rifles-great-again/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	<h3 class="jp-relatedposts-headline"><em>Related</em></h3>
</div></div></article></main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar"><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://missliberty.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search the site ..."><input class="search-form-submit" type="submit" value="Search"><meta content="https://missliberty.com/?s={s}"></form></div></section>
<section id="simple-social-icons-3" class="widget simple-social-icons"><div class="widget-wrap"><ul class="alignleft"><li class="ssi-rss"><a href="https://missliberty.com/feed/" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-3"><title id="social-rss-3">RSS</title><use xlink:href="https://missliberty.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li><li class="ssi-twitter"><a href="https://twitter.com/libertarianfilm" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-twitter" aria-labelledby="social-twitter-3"><title id="social-twitter-3">Twitter</title><use xlink:href="https://missliberty.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-twitter"></use></svg></a></li></ul></div></section>
<section id="featured-post-2" class="widget featured-content featuredpost"><div class="widget-wrap"><h4 class="widget-title widgettitle">Featured Post</h4>
<article class="post-19403 post type-post status-publish format-standard has-post-thumbnail category-featured category-news category-shorts entry" aria-label="That Wasn&#8217;t Real Socialism Claim Torched In One Minute"><a href="https://missliberty.com/that-wasnt-real-socialism-claim-torched-in-one-minute/" class="alignnone" aria-hidden="true" tabindex="-1"><img width="750" height="420" src="https://i0.wp.com/missliberty.com/wp-content/uploads/2021/05/that-wasnt-real-socialism-claim.jpg?resize=750%2C420&amp;ssl=1" class="entry-image attachment-post" alt="that wasn&#039;t real socialism" loading="lazy" srcset="https://i0.wp.com/missliberty.com/wp-content/uploads/2021/05/that-wasnt-real-socialism-claim.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/missliberty.com/wp-content/uploads/2021/05/that-wasnt-real-socialism-claim.jpg?resize=750%2C420&amp;ssl=1 750w" sizes="(max-width: 750px) 100vw, 750px" data-attachment-id="19405" data-permalink="https://missliberty.com/that-wasnt-real-socialism-claim-torched-in-one-minute/that-wasnt-real-socialism-claim-torched-in-one-minute-2/" data-orig-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2021/05/that-wasnt-real-socialism-claim.jpg?fit=1280%2C720&amp;ssl=1" data-orig-size="1280,720" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="That Wasn&#8217;t Real Socialism Claim Torched In One Minute" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2021/05/that-wasnt-real-socialism-claim.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2021/05/that-wasnt-real-socialism-claim.jpg?fit=1024%2C576&amp;ssl=1" /></a><header class="entry-header"><h2 class="entry-title"><a href="https://missliberty.com/that-wasnt-real-socialism-claim-torched-in-one-minute/">That Wasn&#8217;t Real Socialism Claim Torched In One Minute</a></h2></header><div class="entry-content"><p>How do socialists reply to the long-recorded failure of socialism all over the globe? With a pat and prepared answer: that wasn't real socialism. In other words, whatever example you give of socialist failure -- Russia, China, East Germany, Poland, Czechoslovakia, Romania, Yugoslavia, Bulgaria, Hungary, &#x02026; <a href="https://missliberty.com/that-wasnt-real-socialism-claim-torched-in-one-minute/" class="more-link">Continue Reading</a></p></div></article><article class="post-4256 post type-post status-publish format-video has-post-thumbnail category-featured category-news category-shorts tag-libertarianism-101 post_format-post-format-video entry" aria-label="How To Sell Libertarian Ideas (And How Not To)"><a href="https://missliberty.com/sell-libertarian-ideas-not/" class="alignnone" aria-hidden="true" tabindex="-1"><img width="750" height="420" src="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?resize=750%2C420&amp;ssl=1" class="entry-image attachment-post" alt="How To Sell Libertarian Ideas (And How Not To)" loading="lazy" srcset="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?w=1520&amp;ssl=1 1520w, https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?resize=300%2C168&amp;ssl=1 300w, https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?resize=768%2C431&amp;ssl=1 768w, https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?resize=1024%2C575&amp;ssl=1 1024w, https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?resize=750%2C420&amp;ssl=1 750w" sizes="(max-width: 750px) 100vw, 750px" data-attachment-id="4132" data-permalink="https://missliberty.com/how-not-to-talk-to-people-about-liberty/" data-orig-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?fit=1520%2C853&amp;ssl=1" data-orig-size="1520,853" data-comments-opened="0" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="How NOT to Talk to People About Liberty" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?fit=300%2C168&amp;ssl=1" data-large-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/12/how-not-to-talk-to-people-about.jpg?fit=1024%2C575&amp;ssl=1" /></a><header class="entry-header"><h2 class="entry-title"><a href="https://missliberty.com/sell-libertarian-ideas-not/">How To Sell Libertarian Ideas (And How Not To)</a></h2></header><div class="entry-content"><p>First, how not to sell libertarian ideas... You've probably seen libertarian ideas marketed ineffectively--in this short comedy clip, Cathy Reisenwitz and Libertarian Girl demonstrate "how not to talk to people about liberty."  [2 min/ Libertarianism 101]





And second, the best advice... Don't be put &#x02026; <a href="https://missliberty.com/sell-libertarian-ideas-not/" class="more-link">Continue Reading</a></p></div></article><article class="post-2788 post type-post status-publish format-video has-post-thumbnail category-biography category-doc category-featured category-history tag-anti-socialism tag-libertarian-heroes post_format-post-format-video entry" aria-label="Margaret: Death of a Revolutionary (2013)"><a href="https://missliberty.com/margaret-death-of-a-revolutionary-2013/" class="alignnone" aria-hidden="true" tabindex="-1"><img width="750" height="420" src="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/05/margaret-death-of-a-revolutionar.jpg?resize=750%2C420&amp;ssl=1" class="entry-image attachment-post" alt="Margaret: Death of a Revolutionary" loading="lazy" srcset="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/05/margaret-death-of-a-revolutionar.jpg?resize=300%2C169&amp;ssl=1 300w, https://i0.wp.com/missliberty.com/wp-content/uploads/2014/05/margaret-death-of-a-revolutionar.jpg?resize=750%2C420&amp;ssl=1 750w" sizes="(max-width: 750px) 100vw, 750px" data-attachment-id="2790" data-permalink="https://missliberty.com/margaret-death-of-a-revolutionary-2013/margaret-death-of-a-revolutionary-2013-2/" data-orig-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/05/margaret-death-of-a-revolutionar.jpg?fit=1024%2C576&amp;ssl=1" data-orig-size="1024,576" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Margaret: Death of a Revolutionary (2013)" data-image-description="" data-image-caption="" data-medium-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/05/margaret-death-of-a-revolutionar.jpg?fit=300%2C169&amp;ssl=1" data-large-file="https://i0.wp.com/missliberty.com/wp-content/uploads/2014/05/margaret-death-of-a-revolutionar.jpg?fit=1024%2C576&amp;ssl=1" /></a><header class="entry-header"><h2 class="entry-title"><a href="https://missliberty.com/margaret-death-of-a-revolutionary-2013/">Margaret: Death of a Revolutionary (2013)</a></h2></header><div class="entry-content"><p>WINNER: TOP 25 LIBERTARIAN DOCUMENTARIES
Margaret Thatcher rescues Britain from post-WWII socialist policies, liberating a generation from poverty and hopelessness, only to be betrayed in the end by entrenched establishment interests within her own party. [ Margaret: Death of a Revolutionary credits: Dir: &#x02026; <a href="https://missliberty.com/margaret-death-of-a-revolutionary-2013/" class="more-link">Continue Reading</a></p></div></article></div></section>
<section id="tag_cloud-2" class="widget widget_tag_cloud"><div class="widget-wrap"><h4 class="widget-title widgettitle">Themes</h4>
<div class="tagcloud"><a href="https://missliberty.com/tag/abuse-of-power/" class="tag-cloud-link tag-link-43 tag-link-position-1" style="font-size: 17.462962962963pt;" aria-label="Abuse of power (26 items)">Abuse of power</a>
<a href="https://missliberty.com/tag/american-revolution/" class="tag-cloud-link tag-link-55 tag-link-position-2" style="font-size: 13.314814814815pt;" aria-label="American revolution (12 items)">American revolution</a>
<a href="https://missliberty.com/tag/anti-draft/" class="tag-cloud-link tag-link-57 tag-link-position-3" style="font-size: 11.240740740741pt;" aria-label="Anti-draft (8 items)">Anti-draft</a>
<a href="https://missliberty.com/tag/anti-regulation/" class="tag-cloud-link tag-link-9 tag-link-position-4" style="font-size: 18.240740740741pt;" aria-label="Anti-regulation (30 items)">Anti-regulation</a>
<a href="https://missliberty.com/tag/anti-slavery/" class="tag-cloud-link tag-link-59 tag-link-position-5" style="font-size: 10.592592592593pt;" aria-label="Anti-slavery (7 items)">Anti-slavery</a>
<a href="https://missliberty.com/tag/anti-socialism/" class="tag-cloud-link tag-link-22 tag-link-position-6" style="font-size: 22pt;" aria-label="Anti-socialism (59 items)">Anti-socialism</a>
<a href="https://missliberty.com/tag/anti-taxation/" class="tag-cloud-link tag-link-19 tag-link-position-7" style="font-size: 14.222222222222pt;" aria-label="Anti-taxation (14 items)">Anti-taxation</a>
<a href="https://missliberty.com/tag/anti-war/" class="tag-cloud-link tag-link-23 tag-link-position-8" style="font-size: 13.833333333333pt;" aria-label="Anti-war (13 items)">Anti-war</a>
<a href="https://missliberty.com/tag/ayn-rand/" class="tag-cloud-link tag-link-54 tag-link-position-9" style="font-size: 14.481481481481pt;" aria-label="Ayn Rand (15 items)">Ayn Rand</a>
<a href="https://missliberty.com/tag/corrupt-government/" class="tag-cloud-link tag-link-42 tag-link-position-10" style="font-size: 18.62962962963pt;" aria-label="Corrupt government (32 items)">Corrupt government</a>
<a href="https://missliberty.com/tag/creator-as-hero/" class="tag-cloud-link tag-link-50 tag-link-position-11" style="font-size: 20.444444444444pt;" aria-label="Creator as hero (45 items)">Creator as hero</a>
<a href="https://missliberty.com/tag/democide/" class="tag-cloud-link tag-link-40 tag-link-position-12" style="font-size: 19.407407407407pt;" aria-label="Democide (37 items)">Democide</a>
<a href="https://missliberty.com/tag/econ-101/" class="tag-cloud-link tag-link-10 tag-link-position-13" style="font-size: 17.074074074074pt;" aria-label="Econ 101 (24 items)">Econ 101</a>
<a href="https://missliberty.com/tag/eminent-domain/" class="tag-cloud-link tag-link-27 tag-link-position-14" style="font-size: 11.888888888889pt;" aria-label="Eminent domain (9 items)">Eminent domain</a>
<a href="https://missliberty.com/tag/equality-law/" class="tag-cloud-link tag-link-60 tag-link-position-15" style="font-size: 11.888888888889pt;" aria-label="Equality &amp; law (9 items)">Equality &amp; law</a>
<a href="https://missliberty.com/tag/escape-from-socialism/" class="tag-cloud-link tag-link-61 tag-link-position-16" style="font-size: 17.722222222222pt;" aria-label="Escape from socialism (27 items)">Escape from socialism</a>
<a href="https://missliberty.com/tag/freedom-of-speech/" class="tag-cloud-link tag-link-62 tag-link-position-17" style="font-size: 17.851851851852pt;" aria-label="Freedom of speech (28 items)">Freedom of speech</a>
<a href="https://missliberty.com/tag/free-press-as-hero/" class="tag-cloud-link tag-link-63 tag-link-position-18" style="font-size: 11.240740740741pt;" aria-label="Free press as hero (8 items)">Free press as hero</a>
<a href="https://missliberty.com/tag/government-as-bigot/" class="tag-cloud-link tag-link-64 tag-link-position-19" style="font-size: 16.296296296296pt;" aria-label="Government as bigot (21 items)">Government as bigot</a>
<a href="https://missliberty.com/tag/government-as-torturer/" class="tag-cloud-link tag-link-73 tag-link-position-20" style="font-size: 14.222222222222pt;" aria-label="Government as torturer (14 items)">Government as torturer</a>
<a href="https://missliberty.com/tag/government-enforced-morality/" class="tag-cloud-link tag-link-68 tag-link-position-21" style="font-size: 15.259259259259pt;" aria-label="Government enforced morality (17 items)">Government enforced morality</a>
<a href="https://missliberty.com/tag/government-healthcare/" class="tag-cloud-link tag-link-25 tag-link-position-22" style="font-size: 12.407407407407pt;" aria-label="Government healthcare (10 items)">Government healthcare</a>
<a href="https://missliberty.com/tag/government-schools/" class="tag-cloud-link tag-link-21 tag-link-position-23" style="font-size: 12.925925925926pt;" aria-label="Government schools (11 items)">Government schools</a>
<a href="https://missliberty.com/tag/incompetent-government/" class="tag-cloud-link tag-link-15 tag-link-position-24" style="font-size: 17.462962962963pt;" aria-label="Incompetent government (26 items)">Incompetent government</a>
<a href="https://missliberty.com/tag/individualism/" class="tag-cloud-link tag-link-51 tag-link-position-25" style="font-size: 19.925925925926pt;" aria-label="Individualism (41 items)">Individualism</a>
<a href="https://missliberty.com/tag/john-stossel/" class="tag-cloud-link tag-link-80 tag-link-position-26" style="font-size: 16.555555555556pt;" aria-label="John Stossel (22 items)">John Stossel</a>
<a href="https://missliberty.com/tag/law-liberty/" class="tag-cloud-link tag-link-24 tag-link-position-27" style="font-size: 17.462962962963pt;" aria-label="Law &amp; liberty (26 items)">Law &amp; liberty</a>
<a href="https://missliberty.com/tag/legalize-drugs/" class="tag-cloud-link tag-link-6 tag-link-position-28" style="font-size: 16.814814814815pt;" aria-label="Legalize Drugs (23 items)">Legalize Drugs</a>
<a href="https://missliberty.com/tag/libertarian-heroes/" class="tag-cloud-link tag-link-11 tag-link-position-29" style="font-size: 18.240740740741pt;" aria-label="Libertarian heroes (30 items)">Libertarian heroes</a>
<a href="https://missliberty.com/tag/libertarianism-101/" class="tag-cloud-link tag-link-87 tag-link-position-30" style="font-size: 14.87037037037pt;" aria-label="Libertarianism 101 (16 items)">Libertarianism 101</a>
<a href="https://missliberty.com/tag/power-corrupts/" class="tag-cloud-link tag-link-48 tag-link-position-31" style="font-size: 13.314814814815pt;" aria-label="Power corrupts (12 items)">Power corrupts</a>
<a href="https://missliberty.com/tag/power-worship/" class="tag-cloud-link tag-link-49 tag-link-position-32" style="font-size: 9.9444444444444pt;" aria-label="Power worship (6 items)">Power worship</a>
<a href="https://missliberty.com/tag/pro-capitalism/" class="tag-cloud-link tag-link-14 tag-link-position-33" style="font-size: 17.203703703704pt;" aria-label="Pro-capitalism (25 items)">Pro-capitalism</a>
<a href="https://missliberty.com/tag/pro-immigration/" class="tag-cloud-link tag-link-69 tag-link-position-34" style="font-size: 11.240740740741pt;" aria-label="Pro-immigration (8 items)">Pro-immigration</a>
<a href="https://missliberty.com/tag/propaganda/" class="tag-cloud-link tag-link-76 tag-link-position-35" style="font-size: 12.925925925926pt;" aria-label="Propaganda (11 items)">Propaganda</a>
<a href="https://missliberty.com/tag/psychiatric-coercion/" class="tag-cloud-link tag-link-77 tag-link-position-36" style="font-size: 10.592592592593pt;" aria-label="Psychiatric coercion (7 items)">Psychiatric coercion</a>
<a href="https://missliberty.com/tag/resistance-to-tyranny/" class="tag-cloud-link tag-link-53 tag-link-position-37" style="font-size: 15.777777777778pt;" aria-label="Resistance to tyranny (19 items)">Resistance to tyranny</a>
<a href="https://missliberty.com/tag/right-to-secede/" class="tag-cloud-link tag-link-56 tag-link-position-38" style="font-size: 8pt;" aria-label="Right to secede (4 items)">Right to secede</a>
<a href="https://missliberty.com/tag/search-seizure/" class="tag-cloud-link tag-link-86 tag-link-position-39" style="font-size: 13.314814814815pt;" aria-label="Search &amp; seizure (12 items)">Search &amp; seizure</a>
<a href="https://missliberty.com/tag/second-amendment/" class="tag-cloud-link tag-link-20 tag-link-position-40" style="font-size: 14.222222222222pt;" aria-label="Second amendment (14 items)">Second amendment</a>
<a href="https://missliberty.com/tag/sexual-liberty/" class="tag-cloud-link tag-link-65 tag-link-position-41" style="font-size: 15.518518518519pt;" aria-label="Sexual liberty (18 items)">Sexual liberty</a>
<a href="https://missliberty.com/tag/social-tolerance/" class="tag-cloud-link tag-link-52 tag-link-position-42" style="font-size: 15.518518518519pt;" aria-label="Social tolerance (18 items)">Social tolerance</a>
<a href="https://missliberty.com/tag/unions-monopolies/" class="tag-cloud-link tag-link-75 tag-link-position-43" style="font-size: 11.240740740741pt;" aria-label="Unions &amp; monopolies (8 items)">Unions &amp; monopolies</a>
<a href="https://missliberty.com/tag/voluntarism/" class="tag-cloud-link tag-link-47 tag-link-position-44" style="font-size: 12.925925925926pt;" aria-label="Voluntarism (11 items)">Voluntarism</a>
<a href="https://missliberty.com/tag/working-for-government/" class="tag-cloud-link tag-link-72 tag-link-position-45" style="font-size: 14.87037037037pt;" aria-label="Working for government (16 items)">Working for government</a></div>
</div></section>
<section id="tag_cloud-3" class="widget widget_tag_cloud"><div class="widget-wrap"><h4 class="widget-title widgettitle">Genres/Categories</h4>
<div class="tagcloud"><a href="https://missliberty.com/category/action-adventure/" class="tag-cloud-link tag-link-30 tag-link-position-1" style="font-size: 14.794979079498pt;" aria-label="Action-Adventure (56 items)">Action-Adventure</a>
<a href="https://missliberty.com/category/animated/" class="tag-cloud-link tag-link-31 tag-link-position-2" style="font-size: 10.577405857741pt;" aria-label="Animated (10 items)">Animated</a>
<a href="https://missliberty.com/category/biography/" class="tag-cloud-link tag-link-32 tag-link-position-3" style="font-size: 14.73640167364pt;" aria-label="Biography (55 items)">Biography</a>
<a href="https://missliberty.com/category/blog/" class="tag-cloud-link tag-link-90 tag-link-position-4" style="font-size: 15.380753138075pt;" aria-label="Blog (72 items)">Blog</a>
<a href="https://missliberty.com/category/comedy/" class="tag-cloud-link tag-link-7 tag-link-position-5" style="font-size: 14.560669456067pt;" aria-label="Comedy (51 items)">Comedy</a>
<a href="https://missliberty.com/category/doc/" class="tag-cloud-link tag-link-28 tag-link-position-6" style="font-size: 17.07949790795pt;" aria-label="Documentary (140 items)">Documentary</a>
<a href="https://missliberty.com/category/drama/" class="tag-cloud-link tag-link-26 tag-link-position-7" style="font-size: 17.548117154812pt;" aria-label="Drama (170 items)">Drama</a>
<a href="https://missliberty.com/category/family/" class="tag-cloud-link tag-link-33 tag-link-position-8" style="font-size: 12.451882845188pt;" aria-label="Family (22 items)">Family</a>
<a href="https://missliberty.com/category/featured/" class="tag-cloud-link tag-link-98 tag-link-position-9" style="font-size: 8pt;" aria-label="Featured (3 items)">Featured</a>
<a href="https://missliberty.com/category/film/" class="tag-cloud-link tag-link-3 tag-link-position-10" style="font-size: 18.719665271967pt;" aria-label="Film (266 items)">Film</a>
<a href="https://missliberty.com/category/foreign/" class="tag-cloud-link tag-link-34 tag-link-position-11" style="font-size: 13.44769874477pt;" aria-label="Foreign (33 items)">Foreign</a>
<a href="https://missliberty.com/category/history/" class="tag-cloud-link tag-link-94 tag-link-position-12" style="font-size: 15.322175732218pt;" aria-label="History (69 items)">History</a>
<a href="https://missliberty.com/category/horror/" class="tag-cloud-link tag-link-35 tag-link-position-13" style="font-size: 9.0543933054393pt;" aria-label="Horror (5 items)">Horror</a>
<a href="https://missliberty.com/category/music-dance/" class="tag-cloud-link tag-link-29 tag-link-position-14" style="font-size: 12.100418410042pt;" aria-label="Music-Dance (19 items)">Music-Dance</a>
<a href="https://missliberty.com/category/netflix/" class="tag-cloud-link tag-link-89 tag-link-position-15" style="font-size: 17.489539748954pt;" aria-label="Netflix (164 items)">Netflix</a>
<a href="https://missliberty.com/category/news/" class="tag-cloud-link tag-link-95 tag-link-position-16" style="font-size: 22pt;" aria-label="News (980 items)">News</a>
<a href="https://missliberty.com/category/romance/" class="tag-cloud-link tag-link-36 tag-link-position-17" style="font-size: 12.861924686192pt;" aria-label="Romance (26 items)">Romance</a>
<a href="https://missliberty.com/category/scifi-fantasy/" class="tag-cloud-link tag-link-37 tag-link-position-18" style="font-size: 13.037656903766pt;" aria-label="SciFi-Fantasy (28 items)">SciFi-Fantasy</a>
<a href="https://missliberty.com/category/shorts/" class="tag-cloud-link tag-link-5 tag-link-position-19" style="font-size: 18.953974895397pt;" aria-label="Shorts (296 items)">Shorts</a>
<a href="https://missliberty.com/category/thriller/" class="tag-cloud-link tag-link-38 tag-link-position-20" style="font-size: 12.744769874477pt;" aria-label="Thriller (25 items)">Thriller</a>
<a href="https://missliberty.com/category/upcoming/" class="tag-cloud-link tag-link-99 tag-link-position-21" style="font-size: 11.221757322176pt;" aria-label="Upcoming (13 items)">Upcoming</a>
<a href="https://missliberty.com/category/western/" class="tag-cloud-link tag-link-39 tag-link-position-22" style="font-size: 8pt;" aria-label="Western (3 items)">Western</a></div>
</div></section>
</aside></div></div><div class="footer-widgets"><div class="wrap"><div class="widget-area footer-widgets-1 footer-widget-area"><section id="text-2" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">About Miss Liberty</h4>
			<div class="textwidget"><p>This site is a collection of films and documentaries of particular interest to libertarians (and those interested in libertarianism). It began as a book, Miss Liberty’s Guide to Film: Movies for the Libertarian Millennium, where many of the recommended films were first reviewed. The current collection has grown to now more than double the number in that original list, and it’s growing still.</p>
</div>
		</div></section>
</div><div class="widget-area footer-widgets-3 footer-widget-area"><section id="search-4" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://missliberty.com/" role="search"><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Search the site ..."><input class="search-form-submit" type="submit" value="Search"><meta content="https://missliberty.com/?s={s}"></form></div></section>
<section id="simple-social-icons-4" class="widget simple-social-icons"><div class="widget-wrap"><ul class="alignright"><li class="ssi-rss"><a href="https://missliberty.com/feed/" target="_blank" rel="noopener noreferrer"><svg role="img" class="social-rss" aria-labelledby="social-rss-4"><title id="social-rss-4">RSS</title><use xlink:href="https://missliberty.com/wp-content/plugins/simple-social-icons/symbol-defs.svg#social-rss"></use></svg></a></li></ul></div></section>
</div></div></div><footer class="site-footer"><div class="wrap"><p>&#x000A9;&nbsp;2022 <a href="https://missliberty.com/">Miss Liberty's Film &amp; Documentary World</a>. All Rights Reserved</p></div></footer></div><style type="text/css" media="screen"> #simple-social-icons-3 ul li a, #simple-social-icons-3 ul li a:hover, #simple-social-icons-3 ul li a:focus { background-color: #eeeeee !important; border-radius: 0px; color: #222222 !important; border: 0px #ffffff solid !important; font-size: 28px; padding: 14px; }  #simple-social-icons-3 ul li a:hover, #simple-social-icons-3 ul li a:focus { background-color: #222222 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-3 ul li a:focus { outline: 1px dotted #222222 !important; } #simple-social-icons-4 ul li a, #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #eeeeee !important; border-radius: 0px; color: #222222 !important; border: 0px #ffffff solid !important; font-size: 28px; padding: 14px; }  #simple-social-icons-4 ul li a:hover, #simple-social-icons-4 ul li a:focus { background-color: #222222 !important; border-color: #ffffff !important; color: #ffffff !important; }  #simple-social-icons-4 ul li a:focus { outline: 1px dotted #222222 !important; }</style>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/missliberty.com\/jerone-davison-campaign-ad-make-rifles-great-again\/":21438};
	</script>
							<div id="sharing_email" style="display: none;">
		<form action="/jerone-davison-campaign-ad-make-rifles-great-again/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://missliberty.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
<link rel='stylesheet' id='advanced-responsive-video-embedder-css'  href='https://missliberty.com/wp-content/plugins/advanced-responsive-video-embedder/public/arve.min.css?ver=8.10.23' type='text/css' media='all' />
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20191001' id='jetpack-photon-js'></script>
<script type='text/javascript' id='qppr_frontend_scripts-js-extra'>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</script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/quick-pagepost-redirect-plugin/js/qppr_frontend_script.min.js?ver=5.2.1' id='qppr_frontend_scripts-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-content/themes/missliberty/js/theme.min.js?ver=1.0.0' id='missliberty-general-js'></script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/advanced-responsive-video-embedder/public/arve.min.js?ver=8.10.23' id='advanced-responsive-video-embedder-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://missliberty.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.5.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-linkedin' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-linkedin' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202227.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.5.1',blog:'124165910',post:'21438',tz:'0',srv:'missliberty.com'} ]);
	_stq.push([ 'clickTrackerInit', '124165910', '21438' ]);
</script>
</body></html>
